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Some Points to Keep in Mind ……

Please keep your MIC and WEBCAM in MUTE mode until your 

teacher asks you to unmute it.

Please take down notes. 

Ask doubts as and when it comes and write in the CHAT box.

Don’t post any non-academic matter in the chat box. Stringent action 

will be initiated.

 Some times, technology fails, don’t panic, hold on - we will be back.



Spreadsheet

(OpenOffice Calc)

Introduction:
A spreadsheet stores data in the form of a table 
comprising of rows and columns. It is used
to store, arrange, and sort data, and perform 
calculations on numeric data. It is similar to the
ruled paper accounting worksheets traditionally used 
for bookkeeping. 

PLEASE 
WRITE



Spreadsheet

(OpenOffice Calc)

The computerized version of a worksheet is called a 
Spreadsheet application that lets you quickly 
perform calculations on numerical data, represent 
data with charts, analyze, and print. Spreadsheets
are used in various fields such as banking, finance, 
accounting, and education. 

PLEASE 
WRITE





Uses of spreadsheets

Following are some of the popular uses of 
spreadsheets:
1. Managing financial data such as bank account 

information, budgets, transactions,
billing, and receipts.

2.   Handling inventory, reviews, employee 
information, surveys, etc., using data entry
forms.

PLEASE 
WRITE



Uses of spreadsheets

3. Tracking student performance by calculating 
grades and other relevant information such as 
attendance, highest score, and lowest score.

4. Creating lists of items which may not be numeric 
such as student list, grocery list.

5. Managing company information such as profit 
and sales by creating graphs from the data.

PLEASE 
WRITE



Different Spreadsheet applications

There are various spreadsheet applications available 
that can be used to create and manipulate a 
spreadsheet. 
The most commonly used are – Microsoft Office 
Excel, Apache OpenOffice Calc, LibreOffice Calc, 
Google Sheets etc. Microsoft Excel is a proprietary
software from Microsoft for Windows.

PLEASE 
WRITE



Different Spreadsheet applications

Both OpenOffice and Libre Calc are free and open 
source alternatives to Excel. 
Google sheets is a web-based spreadsheet 
application which allows you to store and edit the 
spreadsheets online and access them from any 
computer.

PLEASE 
WRITE



Installing Calc

Calc is offered free of charge and can be downloaded 
from HYPERLINK ‘http://www.openoffice.org’ 
www.openoffice.org calc is the spreadsheet 
component of Apache OpenOffice an open source 
office software suite.

PLEASE 
WRITE



Installing Calc

1.Open the URL: 
https://www.openoffice.org/download/index.html.
2. Select the operating system and language.
3. Click on – Download full Installation
4. Installing OpenOffice on Windows

PLEASE 
WRITE



Installing Calc

Double click on the downloaded exe file and then 
click Next on the following screen:

PLEASE 
WRITE



Installing Calc
Click on Unpack



Installing Calc

After unpacking, click on Next



Installing Calc
Enter User information and then click on Next



Installing Calc

Choose the setup type and then click on Next. It is 
recommended that the beginners should choose 
typical.



Installing Calc

Click on Install



Installing Calc

After installation, click on Finish



Installing Calc

Run OpenOffice to check if it has been installed successfully.
Click on the Spreadsheet to open OpenOffice Calc.



Main Features of OpenOffice Calc

Starting Calc:
To start OpenOffice Calc, there are various ways in which 
you can start it:
• As a Windows application, you can click 

Start -> Programs ->OpenOffice
• If the OpenOffice icon is on the desktop, double click the 

icon.

PLEASE 
WRITE





Title bar

The title bar at the top displays the information 
about the spreadsheet such as name of the current 
spreadsheet (Example Sheet), extension of the 
spreadsheet (.ods), and name of the software 
(OpenOffice Calc). If the spreadsheet is new then its 
name is Untitled N where N is a number. 

PLEASE 
WRITE



Title bar

The ellipsis (three dots ...) in front of an option 
implies that a dialog box will open when this option 
is selected. For example, on selecting the Open 
option, a dialog box will appear which is meant for 
the user to enter the location of the file to be 
opened.

PLEASE 
WRITE



Menu bar

Just below the title bar is the menu bar. 
It contains various menu options.
On selecting a menu option, a submenu appears 
which contains other options related to the main 
menu option.

PLEASE 
WRITE



Menu bar

File: It contains commands to create a new file 
(New), open an existing file(Open), save a file (Save , 
Save As), print a file (Print), preview a page (Preview
Page), close a file (Close), exit the software (Exit) 
etc.

PLEASE 
WRITE



Menu bar

Edit:It contains commands to edit a file such as Cut, 
Copy, Paste, Paste Special, Select All, Find & 
Replace, Delete Contents, Delete Cells, Headers &
Footers.

PLEASE 
WRITE



Menu bar

View: It contains commands to modify the view of 
the Calc such as Toolbars,Full Screen, Zoom. A small 
in front of the Toolbars options means on selecting
it, another submenu appears.
It shows the list of all the toolbars which can be 
selected or deselected based on the user’s choice of
toolbars to be displayed on the Calc main window.

PLEASE 
WRITE



Tool bar options



Menu bar

Insert: It contains commands for inserting Cells, 
Rows, Columns, Sheet,
Sheet From File, Function, Function List, Picture, 
Chart etc.
Format: It contains commands to alter the layout of 
the spreadsheet such as
formatting Cells, altering Rows, Columns, Sheet.
Tools: It contains options to spellcheck (Spelling), 
insert macros (Macros) etc.

PLEASE 
WRITE



Menu bar

Data: It contains commands to manipulate data such as 
Sort, Filter, Validity.
Window: It contains commands to modify the window such 
as New Window,Close Window.
Help: It contains the options getting help related to 
OpenOffice Calc such as OpenOffice Help, What’s This?, 
Check for Updates etc. Placing the mouse pointer on any of 
the icons on the Calc window displays a small box which is 
called a tooltip which gives a brief explanation of the icon’s 
function.

PLEASE 
WRITE



Standard bar

It lies below the Menu bar. It contains icons which 
perform similar operations as contained in the 
Menu bar options such as New, Open, Save, Print,
Page Preview, Cut, Copy, Paste, Sort, Chart, Find & 
Replace, Spelling.

PLEASE 
WRITE



Find bar

It contains a text box which can be used to enter text 
which is meant to be searched in the spreadsheet. It 
highlights the cell which contains the text to be 
searched. Multiple search results can be traversed by 
clicking on the up and down arrows or by pressing the 
Enter key on the keyboard.

PLEASE 
WRITE



Formatting Bar

In the Formatting toolbar, the leftmost icon is for 
the Style & Formatting and the following two boxes 
are the Font Name and Font Size lists. They
show the current settings for the selected cell or 
area. Click the down-arrow to the right of each box 
to open the list.

PLEASE 
WRITE



Formatting Bar

PLEASE 
WRITE



Formatting Bar

PLEASE 
WRITE



Formula bar

PLEASE 
WRITE



Formula bar

PLEASE 
WRITE



Formula bar and Sheets Tab

PLEASE 
WRITE





Status bar

Status Bar: Status bar at the bottom provides 
information about the spreadsheet and
convenient ways to quickly change some of its 
features. Sheet Sequence number shows
the number of the current sheet / total number of 
sheets in the spreadsheet

PLEASE 
WRITE



Status bar

Selected cell (or cells) information is also displayed 
on the Status bar. When a group of cells is selected, 
the sum of the contents is displayed by default. You 
can right-click on this field and select other 
functions, such as the average value, maximum 
value, minimum value, or count (number of items 
selected)

PLEASE 
WRITE



Status bar



Status bar

When the cursor is on an object such as a picture or 
chart, the information displayed includes the size of 
the object and its location. To change the view 
magnification, drag the Zoom slider (bottom left 
corner) or click on the + and – signs.

PLEASE 
WRITE





Sidebar and Active cell

Sidebar: Located on the right side of the edit views 
of Calc, sidebar contains frequently used tools 
grouped in decks such as Properties, Styles and 
Formatting, Gallery, Navigator. Clicking on any of 
the vertical tabs opens the deck for that tab.
Active Cell: When you select a cell, you will notice a 
heavy black border around the
selected cell

PLEASE 
WRITE



Row headers and Column headers

Row Headers: Row headers are in the form of 
numbers -1,2,3.... which are present at the left of 
each row.
Column Headers: Column headers are in the form of 
alphabets – A,B,C,...shown at the top of each 
column.

PLEASE 
WRITE



Working with Spreadsheets

A Spreadsheet consists of a number of individual 
sheets, each containing cells arranged in
rows and columns. A particular cell is identified by 
its column letter and row number. Thesecells hold 
the individual elements—text, numbers, formulas, 
and so on—that make up the data to display and 
manipulate. Each spreadsheet can have many 
sheets and each sheet can have many individual 
cells.

PLEASE 
WRITE



Create a New Blank Worksheet :

There are many ways to create a new blank 
worksheet as discussed below: 

• On the menu bar, click File-> New->Spreadsheet
• On the Standard bar, click on drop-down of the 

New icon-> Spreadsheet

PLEASE 
WRITE





Creating New Blank Spreadsheet Using Standard Bar

On the keyboard type – Ctrl + N.



Open an existing Spreadsheet :

On the menu bar, click File->Open, then a dialog box 
opens up which is used to locate the spreadsheet to be 
opened

PLEASE 
WRITE



PLEASE 
WRITE



Accessing a Cell using Name Box



Accessing a Cell using Name Box

You can also use the Calc Navigator ( ) on the 
Standard bar or Press F5 which opens the following 
Navigator dialog box in which you can enter the row 
number and column letter which you want to 
access.

PLEASE 
WRITE





Cell to Cell Navigation:

Cell to Cell Navigation: You can use the Mouse and 
various keys on the keyboard such as Tab, Enter 
keys, and Arrow keys to navigate from one cell
to another. 

PLEASE 
WRITE



Sheet to Sheet Navigation:

Sheet to Sheet Navigation: Using sheet tabs at the 
bottom of the spreadsheet, you can navigate 
between sheets. If you have a number of sheets, 
then some of the sheet tabs may be hidden behind 
the horizontal scroll bar at the bottom of the
screen. If this is the case, then the four buttons at 
the left of the sheet tabs.

PLEASE 
WRITE





Saving Worksheet:

On the menu bar, click File->Save

While saving a new spreadsheet for the first 
time, a dialog box will open to enter a name 
and select the location for saving the 
spreadsheet.

PLEASE 
WRITE





Closing Worksheet:

On the menu bar, click File->Close
A dialog box opens up if the spreadsheet has not 
been saved. The dialog box gives options to the user 
to Save the file, Discard the changes or Cancel the 
close operation.

PLEASE 
WRITE



Save Dialog Box on Closing a File



Working with Data:

Data – There are various types of data that can be 
entered in a cell:
Labels – These are alphabetic or alphanumeric 
entries without numeric value.They can be a 
combination of letters, numbers, space, special 
characters etc. Labels are left justified by default.
Numbers or Values – These are numeric data which 
may be integers or can contain decimals or 
fractions. Values are right-justified by default.

PLEASE 
WRITE



Working with Data:

Formulas – Used to perform calculations such as 
addition, subtraction, multiplication, division, 
average. Formulas must begin with an = sign.

Entering Data: Data can be entered in an active cell. 
Following are the steps to enter data in say cell A1

PLEASE 
WRITE



Entering Data:

• Click on the A1 cell which is at the top left of the 
spreadsheet. The heavy black border around the 
A1 cell indicates that it is the active cell.

• Start typing some text or numbers say “Room 1” 
and press Enter.

• On pressing Enter the cell below becomes the 
next active cell. Now the active cell is now A2.

PLEASE 
WRITE



Entering Data in Cell A1



Moving Data within a Spreadsheet:

For moving data from one cell to another we
have the cut-copy-paste functions. There are various 
ways to use these functions as described below:

Using the Edit Menu: The Cut, Copy, and Paste 
functions are available in the Edit menu. Following 
example illustrates the steps to do cut/copy-paste 
using Edit Menu:

PLEASE 
WRITE



Using the Edit Menu:

• Select the cell whose contents you want to cut or 
copy (say cell D5).

• Go to the Edit menu on the menu bar and click 
on Cut/Copy.

• Select the cell where you want to paste the 
contents of cell D5 (say cell F5).

• Go to the Edit menu and click on Paste. If you 
have selected Cut option then the contents of D5 
will be removed from D5 and pasted in F5.

PLEASE 
WRITE



Using the Standard bar:

But if you have selected the Copy option, then the 
contents of cell D5 will remain in intact and the 
same will be copied in F5.
Using the Standard bar: The icons are Cut , Copy, 
and Paste.
Following example illustrates the steps to do 
cut/copy-paste using Standard bar:

PLEASE 
WRITE



Using the Standard bar:

• Select the cell whose contents you want to cut or 
copy (say cell D5).

• Click on the Cut / Copy icon in the Standard bar.
• Select the cell where you want to paste the 

contents of cell D5 (say cell F5).
• Click on the Paste icon in the Standard bar.

PLEASE 
WRITE



By Right -Click:

Following steps illustrates how to do cut/copy-paste by 
right clicking on the cell:
• Right-Click on the cell whose contents you want to 

cut or copy (say cell D5). The following menu is 
displayed:

• Select the option Cut/Copy.
• Right-Click on the cell where you want to paste the 

contents of cell D5(say cell F5).
• Select the Paste option.

PLEASE 
WRITE



Right-Click Menu



Using AutoFill:

This feature in Calc is used to automatically 
generate data based on a defined series. A very 
common example is to enter numbers in the
serial number (S.No) column of a table. This is a very 
frequently used column which usually contains 
consecutive numbers. Instead of manually typing 
the serial numbers (say 1 to 100), you can use the 
AutoFill command in Calc.

PLEASE 
WRITE



Using AutoFill:

• Click on the first cell of the serial number column 
and type 1.

• Now drag the fill handle in the bottom right 
corner of the cell (a solid white + sign) across the 
cells that you want to fill (in the given example 
till 5)and release the mouse button. The cells will 
be filled with ascending numbers 2, 3, 4, 5.

PLEASE 
WRITE



Using AutoFill:



Using AutoFill:

Try doing the same exercise with “Monday” typed a 
cell and you’ll observe
that the subsequent cells will be filled with the days 
– Tuesday, Wednesday,….
The AutoFill command also recognizes customized 
sort lists that are defined under menu Tools -> 
Options -> OpenOffice Calc -> Sort Lists. You can 
also define your own sort list.

PLEASE 
WRITE



Creating a sort Lists



Using AutoFill:

In case you want to enter the same value, say, 1 in 
10 consecutive cells simply
press the Ctrl key while dragging the fill handle.
Suppose you want to enter even numbers in a 
column. For example entering
2, 4, 6, 8….20. Then follow the procedure:

PLEASE 
WRITE



Using AutoFill:

i) Type the first two values (2 and 4) in the first two 
cells.

ii) Then select both the cells and drag the fill handle 
of the cell containing value 4. You will observe 
that now the values filled by Calc will be 
6,8,10…20.

PLEASE 
WRITE



Formatting Data

Formatting a document means adding elements of 
style and presentation to documents to improve the 
readability and make them more attractive. To 
enhance the appearance of spreadsheets various 
formatting options are available in the Formatting Bar 
and Format Menu such as alignment, font, size, and 
style. Various formats for numbers are also available
such as percentage and decimals.

PLEASE 
WRITE





Formatting Data

Numbers as Text: Calc evaluates each cell and 
determines whether the entry is a
Value or Label. Cells containing a combination of 
values and text is automatically
treated as a label such as code of a product -
COMP123. Such entries cannot be used
for calculations. 

PLEASE 
WRITE



Formatting Data

However there might be a requirement that a cell 
containing numbers be treated like a label. For 
example telephone numbers, aadhar card number, 
ZIP codes etc. should be treated as labels and not 
values. Whenever such a requirement arises, prefix 
each such entry with a single quotation mark (‘). The 
quotation mark will be invisible and the numbers in 
the cell will be treated as labels.

PLEASE 
WRITE



Formatting Data

Font: Font refers to the design for a set of 
characters. It is the combination of typeface
and other qualities, such as size, pitch, and spacing. 
The font can be changed from the Formatting bar.
Font Name: Various font types are there in Calc such 
as Arial, Arimo, and Century Schoolbook L. The font 
type can be selected from the Font Namebox in the 
Formatting bar.

PLEASE 
WRITE



Formatting Data

Using the drop down, you can select from the list of 
font types available in Calc. The appearance of the
font types listed in the drop down is how the text 
will look when a font type setting is applied

PLEASE 
WRITE



Font Names



Formatting Data

Font Size: Click on the drop down arrow of the font 
size which is next to the Font Name box and then 
select the size you want to use.
Font Style: You can also make the text bold, italics 
or underlined by clicking on the icons available on 
the formatting bar respectively.
Horizontal Alignment: Alignment of data in cell with 
respect to the border of the cells can be done by 
using the Alignment options:

PLEASE 
WRITE



Formatting Data

PLEASE 
WRITE



Formatting Data

Changing Color : You can easily change the color of 
the background of the cells as well as the text color. 
On the left the background color is changed and on 
the right the text color is changed.

PLEASE 
WRITE



Formatting Data

Steps to change the background color of cells:
i) Select the cells.
ii) Click on the Background color icon .
iii) Select the color from the palettePLEASE 

WRITE



Formatting Data

Steps to change the text or font color:
• Select the text or you can select the complete cells.
• Click on the Text color icon .
• Select the color from the palette asPLEASE 

WRITE



Formatting Data

Gridlines and Borders : The gray gridlines (vertical 
and horizontal lines) that you can see in a Calc 
spreadsheet help you while you’re working in a 
spreadsheet. Gridlines appear automatically 
showing you how the data is organized into rows 
and columns. Borders are different from gridlines 
because they help you highlight important
information for people to see.

PLEASE 
WRITE



Formatting Data

Borders need to be added if you want to highlight certain 
cells. One more difference is that gridlines aren’t 
automatically printed, while borders are. Thus, to draw 
borders around a cell or multiple cells, you can use the 
Border icon on the Formatting bar

PLEASE 
WRITE



Formatting Data



Formatting Data

Flow of Text: In order to control the flow of text 
within cells, Calc provides various ways:
Merging / Splitting Cells: In order to merge cells, 
select the cells and click on the Merge Cells icon in 
the Standard Bar. To split the merged cells, select
the cell and click on the Merge Cells icon.

PLEASE 
WRITE



Formatting Data

Wrap Text: It means to break the text into multiple 
lines i.e., adjusting the row height to fit the text 
within the cell but keeping the column width of the
cell same. Steps to wrap text:
i) Right-click on the cell.
ii) Select the option – Format Cells.
iii) A dialog box opens up. Open the Alignment Tab 

and check the option– Wrap text automatically

PLEASE 
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Formatting Data



Formatting Data

Shrink to Fit : This option shrinks the text to fit in 
the size of the existing cell. In this case neither the 
row height nor the column width is changed. The 
text size is decreased according to the cell. Steps to 
shrink the text size to fit the cell:
i) Right-click on the cell.
ii) Select the option – Format Cells.
iii) A dialog box opens up. Open the Alignment Tab 

and check the option– Shrink to fit cell size

PLEASE 
WRITE



Formatting Data

Difference between Wrap Text and Shrink to Fit



Numeric Data Formatting

For more options, right-click on the cell and click on 
Format Cells to open a dialog
Box. Click on the Numbers tab and then you can select 
the category of the format as per requirement.

PLEASE 
WRITE



Numeric Data Formatting



Numeric Data Formatting

• Currency: In the currency format, you can prefix or 
suffix currency symbols to the numeric data. The 
default currency is Rs. which is prefixed to the
number, commas are inserted at the thousand, 
million, billion positions, and two decimal places 
are added to the number.

• Percent: It displays the number as a percentage. 
Two decimal places are added to the number and 
the percent symbol (%) is suffixed at the end.

PLEASE 
WRITE



Numeric Data Formatting

• Standard: It sets the number in the cell to the 
default format by removing any other numeric 
formatting applied.

• Decimals: Decimal places can be inserted or 
removed by using the Add Decimal place or 
Delete Decimal place icon respectively. If you 
want to remove fractional part of a cell or group 
of cells then you can either use the Delete.

PLEASE 
WRITE



Numeric Data Formatting

Decimal place icon on the Standard toolbar or another 
option is to right-click on the cell (s) and then click on 
Format Cells to open the dialog box. On the Number 
tab, you can see the Decimals spin box in the Option 
section. You can increase or decrease the number of 
decimal places by using the up and down arrows. Zeros 
can also be prefixed to the numbers by setting the 
number of zeros to be prefixed in the Leading Zeros 
spin box.

PLEASE 
WRITE



Numeric Data Formatting

PLEASE 
WRITE



Formatting Data

• Date: By default the date format in Calc is 
dd/mm/yy. But in case you want to change the 
format, you can find various date formats in the 
Format Cells dialog box.

PLEASE 
WRITE



Date formats



Finding and Replacing Data:

Data can be searched by using the Find toolbar. If 
you want to find and replace the data then perform 
the following steps:
i) Click on the Edit menu and select the Find & Replace 
option.
ii) A dialog box opens in which you can type the text to be 
searched in the “Search for” text box and the replaced text 
in the “Replace with” text box. You can find or replace the 
results individually (Find or Replace) or all of them at one 
go by clicking on the Find All or Replace All button.

PLEASE 
WRITE



Finding and Replacing Data:

iii) The Match case check box when checked implies 
that the searching is sensitive to the case of the 
text i.e., uppercase and lowercase letters are 
treated differently. Otherwise uppercase and 
lowercase letters are treated as equal.

PLEASE 
WRITE



Finding and Replacing Data:

iv) Entire cells check box when checked implies that 
Calc will search for the whole words that are 
identical to the text to be searched and if the 
text to be searched is part of some other text 
then it will not highlight that in its results.
If this check box is not checked then the text to 
be searched is highlighted even if it is part of cell 
contents.

PLEASE 
WRITE



Finding and Replacing Data:



Deleting

Delete Data: For removing data from a cell, click 
inside the cell (double-click) and then press the 
Backspace key according to the text you want to 
delete. However if you only select the cell (single-
click) and then press the Backspace key then this 
willresult in the deletion of all the text within the 
cell, though the formatting of the cell
remains.

PLEASE 
WRITE



Deleting

Deleting Data and Formatting: Delete key (or Right-
click the cell and select Delete All option) can be 
used to remove data as well as the formatting from 
a cell. Selecting the cell and pressing the Delete key 
opens a dialog box which can be used to delete 
different aspects of the cell. To delete everything in 
a cell (contents and format), check Delete all.

PLEASE 
WRITE



Delete Contents



Deleting

Deleting Cell(s): Single or multiple cells can be 
deleted by selecting them and then right-click and 
select the Delete option. On doing so, a dialog box 
opens which asks the user to shift cells up or left or 
delete an entire row or column after
deleting the cell(s).

PLEASE 
WRITE



Delete Cells



Inserting/Deleting Rows and Columns

Sometimes when you have finished entering data in 
a spreadsheet you may need to add or remove rows 
and columns. One way is to select the row or 
column by clicking on the row header (number) on 
the left or column header (alphabet) on the top and 
then right-click. A menu appears which can be used 
to insert and delete rows or columns and also
adjust the height or width of a row or column.

PLEASE 
WRITE



Row and Column Menus



Insert menu
Insertion of row and columns can also be 
performed by using the Insert menu on the 
Menu bar



Using Formulas and Functions

Formulas can be used for basic operations such as 
addition, subtraction, as well as more complex 
calculations such as income tax calculations, 
averaging. The advantage of using formulas is that 
even if the data is changed, Calc will automatically 
recalculate the answer without the need to rewrite 
the formula again. Another advantage of using 
formulas is that they can be easily copied to a 
number of cells.

PLEASE 
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Example

Let us study some examples of creating basic formulas 
in Calc.
Example 1: Adding data in two numbers and storing the 
result in cell D6.
Step 1: In cell D6, type the equal sign (=). This informs 

Calc that D6 will contain a formula.
Step 2: Now type 4+5
Step 3: Press Enter
Cell D6 will contain 9. You can see the formula (=4+5) in 
the Input line in the
formula toolbar

PLEASE 
WRITE



Example



Using Formulas and Functions

In Calc, a cell reference identifies the location of a cell or 
group of cells in the worksheet. The cell reference is also 
called address of a cell. Cell references are used in formulas, 
functions, and other commands.
Individual cell reference: Each cell is identified by its column 
letter and row number in this order. For example, the cell 
reference of the topmost and leftmost cell is A1
(Column=A, Row=1).

PLEASE 
WRITE



Using Formulas and Functions

Range of cells – You can use cell referencing for a 
consecutive range of cells also using a colon (:). For 
example, cell reference for the range of first five cells in 
column D is D1:D5 (i.e., D1, D2, D3, D4, and D5). Cell 
reference for the range of first five cells in row 5 is A5:E5 
(i.e., A5, B5, C5, D5, and E5). Cell
reference for a group of four cells spanning first 2 columns 
and first 2 rows of
the spreadsheet is A1:B2 (i.e., A1, A2, B1, and B2).

PLEASE 
WRITE



Using Formulas and Functions

When you wish to add a reference to a cell in some other 
cell then there are two ways. First is to type the cell 
reference using the keyboard. Second is using the mouse. 
The steps to insert cell reference using the mouse is as 
follows:
Step 1: Double-Click on the cell in which you want to insert 

cell reference.
Step 2: Type equal sign (=)
Step 3: Now click on the cell whose reference you want to 
add. On clicking you will notice that the address of the cell 
which you have clicked is inserted.

PLEASE 
WRITE



Using Formulas and Functions

For example, steps to add data in two cells D4 and D5 
and store the result in cell D6.
Step 1: Enter numbers in cell D4 and D5.
Step 2: Double-click on the cell D6 and type =.
Step 3: Click on cell D4. The address D4 will be inserted 

in cell D6 after the = sign.
Alternatively you can type D4.
Step 4: Type plus sign (+) in cell D6.
Step 5: Click on cell D5, The address D5 will be inserted 
in cell D6 after the + sign. Alternatively you can type 
D5.Formula in cell D6 =D4+D5. 

PLEASE 
WRITE



Using Formulas and Functions

After you press Enter, D6 will contain the sum of the 
numbers stored in cells D4 and D5.
You can view the formula of cell D6 in the Input line 
of Formula toolbar as shown in . If you double-click 
on cell D6, then also you can see the formula in cell 
D6.

PLEASE 
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Adding Contents of Two Cells



Adding Contents of Two Cells

Try changing the values in cell D4 and D5 and you will 
observe that the result in cell D6 will be automatically 
recalculated and updated. This is one of the most 
important use of Calc.

PLEASE 
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Type of Operators

PLEASE 
WRITE



Type of Operators

PLEASE 
WRITE



Precedence of Operations:

If multiple operators occur in a formula then the calculation is 
performed by using the following order:
1. Operations enclosed in parentheses.
2. Exponentiation.
3. Multiplication and division. (If both multiplication and 

division occurs in a formula then the calculation is performed 
from left to right.)

4. Addition and Subtraction. (If both addition and subtraction 
occurs in a formula then the calculation is performed from 
left to right.)

PLEASE 
WRITE



Example of precedence of operations

For example, consider the following formula:
=1000+3000*500
In the above formula, multiplication will be performed first 
and then addition will be
performed. If you want to perform addition first then you 
have to enclose the addition
operation in parentheses as shown below:
= (1000+3000)*500

PLEASE 
WRITE



Functions

Calc has a set of predefined formulas called functions. 
They differ from formulas in the sense that in a formula 
we provide both the operands and the operator, 
however in functions we only provide operands (or 
arguments) as functions have predefined operation to 
be performed on the arguments. Just like a formula, the 
function also begins with an equal (=) sign. 

PLEASE 
WRITE



Functions

We specify the arguments enclosed in parenthesis () 
and separated by a comma (,). For example, SUM 
function is used to add as shown below:
= SUM (3, 4) – This will add numbers 3 and 4.
= SUM (A3, A4) – This will add numbers in cell A3 

and A4.
= SUM (3, 4, A3, A4) – This will add number 3, 4, 
contents of cell A3 and A4.

PLEASE 
WRITE



Commonly used mathematical functions in 

Calc :

1.PRODUCT (n1; n2…) – To calculate the product of 
arguments n1, n2…

2. SQRT (n) – To calculate the square root of a number n.
3. POWER (n; p) – To calculate power p of a number n.
4. LOG (n; b) – To calculate log a number n to base b.
5. ROUND (n; d) – To round a number n to digits d.
6. SIN (n), COS (n), TAN (n) – To calculate sine, cosine and 

tangent of n.

PLEASE 
WRITE



7. RANDBETWEEN (f; l) – Returns a random number 
between  f and l.

8. QUOTIENT (a; b) – To calculate integer quotient of 
division a/b.

9. ABS (n) – To calculate the absolute value of a 
number n.

10. AVERAGE (n1; n2….) – To calculate average of 
arguments n1, n2…

Commonly used mathematical functions in 

Calc :

PLEASE 
WRITE



For the function which contains multiple arguments 
such as SUM (), PRODUCT (),AVERAGE (), if the 
arguments are consecutive then you can use a range 
of cells such as A1:A5 which means cells A1, A2, A3, 
A4, and A5.

PLEASE 
WRITE

Commonly used mathematical functions in 

Calc :



For example, addition of the numbers in cells 

A1:A5 in cell A6 is shown

PLEASE 
WRITE



Relative and Absolute Addressing 

Relative Addressing
The cell in column A, row 1 is addressed as A1. You can address 
a range of adjacent cells by first entering the coordinates of the 
upper left cell of the area, then a colon followed by the 
coordinates of the lower right cell. For example, the square 
formed by the first four cells in the upper left corner is 
addressed as A1:B2.By addressing an area in this way, you are 
making a relative reference to A1:B2. Relative here means that 
the reference to this area will be adjusted automatically when 
you copy the formulas.

PLEASE 
WRITE



Relative Addressing



Relative Addressing



Absolute  Addressing

Absolute Addressing: In some cases the requirement is to 
retain the cell address even if it is copied to some other cell or 
when using AutoFill. In such cases, absolute addressing is 
used. Dollar signs ($) are used to hold a column and/or row 
address constant. When you enter an address in a cell that is 
prefixed with a $ sign, then Calc stores the absolute address 
of the cell.

PLEASE 
WRITE



Absolute  Addressing



Mixed Addressing 

Mixed Addressing : Sometimes a combination of 
absolute and relative addressing is usedsuch as $A3, 
B$5, A5+$B4, $A1+B$1. In such cases, whichever 
part (row or column) is prefixed with $ remains 
unchanged and the ones not prefixed with $ are 
calculated in a relative manner.

PLEASE 
WRITE



Mixed Addressing



Sorting and Filtering Data

Sorting: Data can be easily sorted in Calc by using 
the sort command available on the Standard toolbar 
(Sort Ascending , Sort Descending ) and also in the 
Data menu which opens a dialog box for more 
options.

PLEASE 
WRITE



Sort Dialog Box



Steps to sort using the Standard 

Toolbar:

Step 1: Select the cells you want to sort.
Step 2: Click on the Sort Ascending icon on the 

Standard Toolbar.
Data will be sorted according to the first column of 
the selected cells.

PLEASE 
WRITE



Steps to sort using the Sort 

command:

Step 1: Select the cells you want to sort.
Step 2: Click on the Sort option in the Data menu 

which opens a dialog box.
Step 3: You can change the select the column based 

on which you want to sort the data. Also you 
can select the Ascending or Descending option.

Step 4: Click on OK

PLEASE 
WRITE



Sorting using Multiple Columns:

You can also select multiple criteria (up to 3) to sort 
with each criterion applied one after the other. For 
example, you have the following data as given in Table 
and you want to sort it in ascending order according to 
the price per item and then if two items have the same 
price then in descending order of the number of items 
and if two items have the same price and the number 
then according to their code sorted alphabetically in 
increasing order.

PLEASE 
WRITE



Example

PLEASE 
WRITE



Steps to do sorting using multiple 

columns
Step 1: Select the cells you want to sort including the 
headings
Step 2: Since the data you have selected contains headers 

(Price per Item and Number of Items) which you 
don’t want to be included in sorting then open the 
Options tab in the same dialog box and check the 
option Range contains column headers.

Step 3: Click on the Sort option in the Data menu which 
opens a dialog box.

Step 4: In the Sort by section select the Price per Item 
column and ascending radio button.

PLEASE 
WRITE



Steps to do sorting using multiple 

columns

Step 5: In the Then by section select the Number of 
Items column and descending radio button.

Step 6: Lastly in the next Then by section select the 
Item Code and ascending radio button

Step 7: Click on OK

PLEASE 
WRITE





The result after sorting

PLEASE 
WRITE



Filtering Data 

Applying a filter means displaying data based on 
some conditions or filters. Filters can be applied by 
using the Filter option in the Data menu. Three 
types of filters can be applied – AutoFilter, Standard 
Filter and Advance Filter. Let us study AutoFilter and 
Standard filter in detail.
AutoFilter – This filter is added on the topmost row 
of the selected data in the form of a drop down list 
from which you can select data to be displayed or in
other words apply filters.

PLEASE 
WRITE



Filtering Data Example

Given the following data in the table, the following are the 
steps to apply Auto Filter to display all the Female 
candidates.



Filtering Data Example

Step 1: Select the data
Step 2: Select Data menu and click on Filter >AutoFilter
Step 3: On the topmost cell of each column you will 

observe drop-down boxes. Click on the drop 
down in the gender column and you will see all 
the unique values in that column.

Step 4: Select the Female entry in the drop-down

PLEASE 
WRITE



Filtering Data Example



Filtering Data Example

The resulting sheet will contain all the female entries and 
the drop-down in the column in which filter is applied 
(Gender) will be colored in blue



Filtering Data Example

You can apply filters to other columns also. Suppose in the 
above example, data was to be filtered for all the females 
students having 98 marks. Then click on the drop-down of 
the Marks column and select the 98 entry in the drop-
down. The output will be as shown



Standard Filter

Standard filter is used to provide more options for 
filtering such as combining multiple filters by using 
AND and OR operator. AND operator implies that all 
the filters must be satisfied for displaying the data.
OR operator implies that at least one filter should
be satisfied for displaying the data.
AND Operator Example - Suppose in the Table, you 
have to select the male students having more than 75 
marks. Following are the steps to filter data based on 
this criterion:

PLEASE 
WRITE



AND Operator Example
Step 1: Select the data
Step 2: Select Data menu and click on Filter->Standard 
Filter. A dialog box will open.
Step 3: Add the criteria for Gender = Male AND Marks > 75
Step 4: Click on Ok. The output will be as shownPLEASE 

WRITE



Standard Filter

OR Operator Example – Suppose in the Table , you 

have to select the female students or students having 

more than 75 marks. Following are the steps to filter 

data based on these criterion:

PLEASE 
WRITE



Standard Filter

Step 1: Select the data
Step 2: Select Data menu and click on Filter->Standard Filter. 

A dialog box will open.
Step 3: Add the criteria for Gender = Female OR Marks > 75
Step 4: C lick on Ok. The output will be as shown

PLEASE 
WRITE



OR Operator Example



OR Operator Example - output



AND-OR Operators Example

AND-OR Operators Example - Suppose in Table 3, you have 
to select the female students whose name begins with the 
letter “S” or male students whose name begins with letter 
“G”. Following are the steps to filter data based on this 
criterion:
Step 1: Select the data
Step 2: Select Data menu and click on Filter->Standard Filter. 

A dialog box will open.

PLEASE 
WRITE



AND-OR Operators Example

Step 3: Add the criteria for Gender = Female AND 
Name of the Students Begins with
“S” OR Gender = Male AND Name of the Students 
Begins with “G”
Step 4: C lick on Ok. The output will be as shown

PLEASE 
WRITE



AND-OR Operators Example



OUTPUT



Removing AutoFilter

Removing AutoFilter – Select the cells as selected 
while adding the filter. From the Data menu, select 
Filter->Remove Filter. The filters will be removed. 
The screen shot is shown in the next slide.

PLEASE 
WRITE





Creating Charts and Graphs

In Calc, you can create graphs and charts to represent 
the data graphically. Some times, it is very difficult to 
analyze spreadsheets containing huge amount of data. 
For example, analyzing the academic performance of 
students of a school over the past 10 years. Such
analysis can be done effectively by using charts which 
provide a visual presentation of data.

PLEASE 
WRITE



Creating Charts and Graphs

Various types of charts can be created in Calc. 
It offers a choice of 10 chart types such as 
Column chart, Bar chart, Pie chart, Area chart. 
Each of the chart types has several sub-types.

PLEASE 
WRITE



Creating Charts and Graphs

Following are the steps required to insert a chart:
Step 1: Select the data which is to be included in the 

chart.
Step 2: Go to the Insert menu and select the Chart option 

as shown, another way is to click on the Chart icon 
in the Standard toolbar.

Step 3: Chart wizard dialog box is displayed as shown in 
which is used to insert various options related to 
the chart such as the type of chart, data 
range, data series and elements of the chart.

Step 4: Select the chart type (Column chart, Bar chart, Pie chart 
etc.) and click on the Finish button.

PLEASE 
WRITE







Example

PLEASE 
WRITE



Column Chart:

A Column chart is used to compare values across 
categories by using vertical bars. The Column chart can 
be inserted by selecting the Column option in the 
Chart type of the Chart Wizard. You can also select 
from the various subtypes of Column chart from the 
Wizard. The Normal Column chart for the data

PLEASE 
WRITE



Column Chart:

PLEASE 
WRITE



Bar Chart:

A Bar chart is the horizontal version of a column 
chart. It is used if you have large text labels. Select 
the Bar chart option in Step 3 above to create a 
Normal Bar chart for the Table is shown.

PLEASE 
WRITE



Bar Chart:

PLEASE 
WRITE



Pie Chart :

A Pie chart is used to display the contribution of 
each value (slice) to a total (pie) i.e., it can be 
used to plot various pieces of a single entity. 
The Normal Pie chart for Table is shown.

PLEASE 
WRITE



Pie Chart :

PLEASE 
WRITE



Line Chart :
A Line chart is used to compare trends and changes in values 
over time. The line chart (lines only) for the data in Table as 
shown.

PLEASE 
WRITE



Scatter Chart :

A Scatter chart is used to display relationships 
between variables. The scatter chart for the data in 
the previous Table is shown. Note that the X axis 
labels are not the month names as in the case of line 
chart but numbers.

PLEASE 
WRITE



Scatter Chart :

PLEASE 
WRITE



Inserting Title : You can insert title and subtitle of the 
graph and titles of X-axis and Y-axis in the Chart 
Elements of the Chart Wizard as shown.

PLEASE 
WRITE



After inserting the chart elements, the Points 
and Lines chart for the previous  Table is shown.

PLEASE 
WRITE



Legends :

Most commonly located on the right of the chart, 
legends help the readers of the chart to decode the 
charted data by associating descriptive text with the 
colors or patterns of data in the chart.
You can modify the placement of legends or even 
remove them in the chart by using
the Chart Wizard->Chart Elements as shown in the right 
panel

PLEASE 
WRITE



To make the data in a chart that displays axes easier 
to read, you can display horizontal and vertical chart 
gridlines. 
By default the horizontal gridlines are displayed.
You can turn on and off the gridlines by using the 
Chart Wizard->Chart Elements as shown before.

PLEASE 
WRITE

Grids:



Resizing and Moving Charts

After the chart has been inserted, you can easily 
move and resize it. Click anywhere in the chart area 
and drag it to another position in the spreadsheet 
for moving the chart. For resizing it, click on the 
chart and then click and drag any of the chart 
resizing handle (Eight green small squares on the 
border of the chart as shown

PLEASE 
WRITE



Deleting and Modifying 

charts

Deleting Charts: Select the chart and then press the 
Delete key on the keyboard for deleting a chart.
Modifying Charts: After the chart has been inserted 
you easily modify the chart. Double-click on the 
chart and then right- click. You can see various 
options such as Chart type, legends, titles, as shown

PLEASE 
WRITE



Modifying charts



Macros

A macro is a recording of each and every command 
and action you perform to complete a task. A macro 
records your mouse clicks and keystrokes while you 
work and play them back later. When you run the 
macro, it plays those actions back in the exact same 
order. Thus, if you want to repeat the actions 
multiple times you just need to run the macro.

PLEASE 
WRITE



1.Go to the Tools tab on the Menu bar->Macros-> 
Record Macro as shown.

Observe a small dialog box has appeared on the 
worksheet displaying Stop Recording.
2. Calc has started recording the Macro. Until you 

stop the recording, every Calc command and 
keystroke will be recorded in the macro, in the 
order in which they are entered.

PLEASE 
WRITE

Create/Record Macros:



Create/Record Macros:

Suppose the following tasks were performed:
a) We created all borders in the cells A1:C3.
b) Then we changed the background color of cells 

A1:C3 to green.

PLEASE 
WRITE



Create/Record Macros:

3. After we have done all the required tasks, we will 
stop recording the macro by clicking on the Stop  
recording option on the dialog box . A new dialog 
box will open (OpenOffice Basic Macros) in which 
you have to specify the name of the macro and the 
location for saving it (We have named the macro
as Color Change and saved it in My Macros folder) 
as shown.

PLEASE 
WRITE







Run/Use Macros created:

Now we have a macro that can perform in a single 
operation all the tasks we have performed
during recording of the macro.
Run/Use Macros created:
Following are the steps to run/use a macro that we have 
already created:
1. Go to the Tools tab on the Menu bar->Macros->Run 

Macros.
2. A dialog box will open, showing all the macros 

created. We will select the one to run and then click on 
Run button.

PLEASE 
WRITE



Run/Use Macros created:

3. The tasks performed during recording of the macro 
will be repeated in the same order
in which they were performed. (Running ColorChange
Macro will create borders around the cells A1:C3 and 
set their background color to green.)
By default, recorded macros use absolute cell 
referencing, which means that exact cell
locations are recorded into the macro.

PLEASE 
WRITE





Delete Macros:

Following are the steps to delete a macro that we have 
already created:
1. Go to the Tools tab on the Menu bar->Macros-> 

Organize Macros and select the OpenOffice Basic 
option.

2. A dialog box listing the macros created will open as   
shown in Figure. Select the macro you want to 
delete and then click on the Delete button.

PLEASE 
WRITE





Printing Spreadsheets

Calc offers various options for printing spreadsheets. 
Many details can be selected for what is to be printed 
and what not. For printing, open the File tab on the 
Menu bar and select the Print option. A dialog box will 
open in which you can select various options such as:
1. All Sheets, Selected Sheets or Selected Cells.
2. All pages or specific pages. Specific page numbers 
separated by comma or range of pages (such as 1:10) 
can be entered in the Pages box.

PLEASE 
WRITE



3. Number of Copies
After selecting the options, click on Print to print the 
spreadsheet(s).



OLD SYLLABUS-JULY 2020

(REMOVED)



NEW SYLLABUS-JULY 2020

+ TROUBLE SHOOTING SOFTWARE,HARDWARE

(NEWLY ADDED)

(NEWLY ADDED)



Any Questions?


